Probleme mit Updates bei build&capture

Microsoft veröffentlicht seine Updates jeweils am Patch Tuesday. Danach verteile ich die Updates jeweils mit SCCM. Zusätzlich dazu erstelle ich mit einem sogenannten build&capture Vorgang ein neues Grundimage mit den neuen Updates, das verwendet wird, wenn ein Computer neu aufgesetzt wird. Damit ist sichergestellt, dass ein neu aufgesetzter Computer bereits beim ersten Start über die sicherheitsrelevanten Updates verfügt und nicht erst danach die vielen Updates seit der Imageerstellung installieren muss. Es gibt aber ein grundsätzliches Problem bei vielen Updates, dass sich aber durch einen Hotfix von Microsoft beheben lässt.

Nun bin ich aber auf ein neues Problem gestossen. Bei der Installation der Updates bricht der Vorgang am Schluss ab und die build&capture Tasksequenz wird nicht bis zum Ende durchgeführt, sondern bricht ab und wird weiterhin als “wird ausgeführt” angezeigt. 

image

Nach diversen Tests konnte ich es auf die folgenden KB Artikel eingrenzen:

KB 982671: The.NET Framework 4 is available on Windows Update
KB 982670: The .NET Framework 4 Client Profile is available on Windows Update
KB 2529073: Binary files in some USB drivers are not updated after you install Windows 7 SP1 or Windows Server 2008 R2 SP1

Ausserdem tritt das Problem nur bei der 64bit Tasksequenz auf. Da es sich um schon ältere Updates handelt, muss etwas neueres mit diesen in Konflikt stehen. Nach Recherchen im Internet musste ich feststellen, dass viele Probleme mit Updates installieren bei einer build & capture Tasksequenz haben, vor allem mit den .NET Frameworks, wie das bei mir ja nun auch der Fall war.

Daher habe ich auf die 3 Updates verzichtet und dafür das .Net Framework 4 als Installationsdatei heruntergeladen und in die Tasksequenz eingebaut. 

Nachdem man das Paket erstellt hat, kann man die Software mit dem Schalter /q installieren.

image

Die .NET 4 Installation habe ich nach den Updates gemacht.

image

Somit kann ich immer noch nicht genau sagen, wieso die Installation der Updates abbricht. Wahrscheinlich hat es mit einer Reihenfolge der Installation zu tun, die drei Updates sind ja schon älter. Wie der Konflikt entsteht oder wie man ihn umgehen könnte, kann ich nicht sagen. Aber mit der manuellen Installation ist gewährleistet, dass das System vollständig gepatcht ist. Dies muss im Moment genügen, für weitere Nachforschungen fehlt einfach auch die Zeit.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s