Problem mit OSD

Neuaufsetzen von nicht bekannten Computern hat mit dem neuen SCCM problemlos funktioniert. Wenn aber einer dieser Computer bereits bekannt ist und erneut neu aufgesetzt werden sollte, brach die Tasksequenz mit folgender Meldung ab:

BOM not found on policy reply

Failed to download policy {irgendeine Nummer} (Code 0x80004005).

image

Gemäss diesem Technet-Blog hat das mit einem Windows Update zu tun, das nicht mehr ausgeliefert wird, aber in der Datenbank nicht vollständig gelöscht wurde.

Im Blog werden zwei Möglichkeiten beschrieben. Die erste ist, beim Neuaufsetzen keine Updates mehr ausliefern (ist ja nicht so wichtig, da die meisten beim build&capture Vorgang schon ins Grundimage aufgenommen werden. Da es aber später auch Updates von Updates geben wird, wollte ich darauf nicht verzichten. Ziel soll es sein, nach dem Neuaufsetzen ein möglichst aktuelles System mit allen Updates zu erhalten. Also musste ich den zweiten beschriebenen Weg gehen und mit dem Microsoft SQL Server Management Studio die entsprechenden Einträge aus der Datenbank löschen.

image

Bei mir gab es zwei Einträge, die ich beide sowohl von “PolicyAssignment” als auch von “DepPolicyAssignment” löschen musste. Danach funktioniert das Neuaufsetzen auch mit aktiviertem Software Update Schritt wieder problemlos.

image

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s